Sunday, 22 December 2013

Half Hood

Managed another quick blat around Blithfield Reservoir yesterday before the rain closed in. Second gear provided more lateral movement that forward movement, but that just widened my grin. Its great to ge the blood coursing through your veins again on a cool fresh morning.
With the onset of more poor weather I decided to install the half hood that has been sitting patiently in its box since the summer. I bought it from SoftBits4Sevens along with a shower cap. The logic behind this was: half hood for driving and shower cap for stationary/overnight. Together they were less that half the price of full weather gear from GBS.
Fitting turned out to be quite straight forward. At the rear the half hood fixes to the base of the rollbar supports where they meet the rear valance. No new holes necessary, just add the nylon loops to the existing anchor points. The windscreen mounting was not so simple as it involved drilling into the u-channel windscreen surround whilst the windscreen was in place. The edge of the glass was encountered on a couple of the holes, but the screen remained in one piece even with the rivets in place. Finally the side anchor points. I chose to overlap the boot cover slightly as the forward corners of the boot cover had a habit of turning out whilst driving. Overlapping them allowed me to add another popper and keep them tidy.
I think the hood look good, even though it is a cold day so the creases haven't pulled out. It is also not as difficult as I thought to get in with the hood up as I had feared.

Sunday, 15 September 2013

Just driving.....


Have spent every possible moment driving this wonderful machine since it was registered. The AICV still isn't working but the car runs (and boy does it run), so why spend valuable driving time in the garage. These little things can be fixed when it's Pisxxg down.
Almost 800 miles on the clock now without really going anywhere, but where I have been has been with gusto :-)
Half hood and ShowerCap on order from SoftBits. Should give me a little more range now Autumn is with us.

Saturday, 17 August 2013

Niggles

The problem with the wipers was simple to address. The wipers had got themselves stuck on the windscreen and the motor had blown the fuse. Simple to fix but the dash had to come out first.

The problem with the IACV is not that straight forward. When the car went for it's pre-test checks at GBS, Simon@GBS couldn't get the IACV to work properly. The valve itself seems to be working in that it made noises and displayed a % on the Emerald control screen that could be manually altered, but it didn't seem to have any noticeable affect on the engine.
Richard@GBS said he had fixed it when I went to pick the car up, but it has since reacted in exactly the way Simon@GBS had seen to the point where I turned it off in the ECU - which hasn't made any noticeable difference to the engine idle.

The Emerald web site states that :

Two pin Idle Air Control Valves (IACV's) - how should they be wired up?
Wire one pin on the valve to an ignition fed +12v supply.  The other side goes to pin 3 (IACV Valve channel 1) on the Emerald ECU.  In the PC software go to ECU Configuration and "Idle Air Control Valve motor options" and select 300Hz as the PWM value.  If the configuration has to be changed then click the OK button and reset the ECU by switching the ignition on and off.  Read up the map from the ECU and go to the "Idle Control" tab - press F5.  Select “motor control mode” in the top right hand corner of this screen.  Set the mode to “Fixed position manual control."  Re-program the map to the ECU.

From the "live adjustments" tab (F8), and with ignition ON, engine OFF, use the page up/page down keys to alter the motor setting.  The valve is, in effect, an air injector so you should hear the motor buzzing as you increase the IACV position above about 20%.  Note that the valve will not work at very low settings or very high settings - the normal operating range is between 30% and 70%.  You can test this before starting the engine when the valve noise should be very obvious.
Having looked at wiring Richard@GBS introduced, he has one wire to the ECU and the other to ground. Having just swapped this to positive the engine simply stops after a couple of seconds. So I put everything back to where it was so I have a working car again. After thinking about this it has occurred to me that perhaps the engine stopping was actually the right result. If the valve was actually working for the first time but closed, then this is exactly what would happen. I will try again when I have more time

Tuesday, 13 August 2013

Finally Registered



Two weeks ago Ruth@GBS sent me my registration paperwork. I haven't had time to blog the fact because I have been out driving :-). 

I've now done 250 miles getting a feel for the car and how it performs - and boy does it perform !! It's potential for speed is far greater than my skill to control it at the moment, but I'm learning with every drive how the chassis reacts to power whilst cornering, how the wind can suffocate you over 80, how the front tyres pick up anything from the road surface and hurl it in your general direction, but more importantly the forgotten thrill of an open top sports car - superb !!

There are some niggles that I will need to get around to fixing - but only when its raining. Namely the IACV is not working. I don't think it ever has worked properly. The windscreen wipers stopped working the first time they jammed on the top of the screen. Other than that all is well and running sweetly.

Sunday, 14 July 2013

Yet more disappointment

I hear today that the current spell of excellent weather is the best for 7 years. Imagine my disappointment to have my car sitting in the garage unable to be driven - gutted :-(
Another week has gone by and some box-ticking bureaucrat in Swansea has taken another week (now three) to perform a 15 minute over the counter vehicle registration. If this is the British governments idea of initiating process efficiency we are all doomed.
I have avoided going in the garage for the past few weeks. I can't resist the temptation just to start her up and go for drive, but today I did install the boot cover and bring her out for some photographs.


Saturday, 29 June 2013

Collection Day


The day has finally arrived.....
A last minute problem with the IACV delayed proceedings but as you can see above, Richard@GBS did a final test drive before handing over the keys.
60 miles later and I am home and still buzzing - what a drive - and I built it myself - awesome!!



Monday, 17 June 2013

IVA

Had a call whilst at work today from GBS.
My car passed its IVA first time !!!!
I have no other details as it was about 4:30 and Simon@GBS had just got back. I will phone him tomorrow to understand the detail and what happens next.
Very big grin :-)

Friday, 31 May 2013

Back to GBS


... and off she went back to GBS for final checks, some set-up that I can't do i.e. suspension and engine mapping, and the VOSA test. Fingers crossed.

Thursday, 30 May 2013

Bonnet and IVA trim

Before putting the car finally back together, the IVA trim has to be added to the edges of any exposed panels especially around the front suspension. This is a frustrating and tricky job when the car is built. Had I known it would have put the trim on before the suspension. Another note for the GBS installation notes.


If you have been reading my blogs then you will know my philosophy regarding the final finish for the aluminium panels. So the next and final panel to polish is the bonnet.



And here it is all put together........


Interior Trim



Seems like I am on the home straight now. GBS have sent off the paper work to VOSA. I have the local garage arranged to move the car to Newark on Friday. Just need to finish off what I can before then. There will be a small list of things I will need to ask GBS to do for me, for example the front wheel/steering geometry, and also anything I simply don't get done by Friday. I would prefer to continue with the Friday timeline than delay if I am not quite ready.
Before I can complete the centre console the carpet needs to go in. I opted for the laser cut carpets from GBS. After sorting out where all of the bits went the installation was very straightforward. I don't think I had to trim anywhere.  Wow is that glue good. Even with the garage door wide open my head was swimming and then aching with the fumes. The carpets transform the look of the interior of the car. All of assudden it starts to look finished.
My thoughts on the centre console were to use the minimum of fixings to keep the cabin looking simple and tidy. Two for the elbow section between the hand brake and rear panel. Four for the centre section and four for the auxiliary panel. It was then I found that I needed to remove the dash to install the auxiliary panel. But only after breaking the horn switch in the process - damn. Next day delivery from Amazon- I will fix it tomorrow. With the dash out it is much easier to find the right position for the auxiliary panel and drill the holes for the rivnuts. In order to make the centre console fit properly I did need to reduce the centre panels length slightly. Not that easy as the vinyl had already been glued down. I also had to widen the gap for the handbrake lever to make space for the handbrake switch to fit through. The final job was to stick the gaiters for the handbrake and gear stick to the underside.
Next up is the chrome trim for the door openings and floor. Oddly these weren't cut to the correct lengths and required some adjustment before I could drill the 3.2mm holes for the stainless steel rivets. I am not sure about IVA for the side pieces. I haven't put any trim around them as they fit so snugly against the side panels. Fingers crossed.
Finally, and to complete the interior, the seats and seat belts. I had already cleaned the threads for the seat belt mounting points and drilled the floor pan for the seat runners, so both were fairly quick jobs.
Looks great !!!


Front and rear wings


Having waited for the tadpole trim to adhere to the wings, they now need to be fixed to the panels. Whilst the panels are pre drilled, once the inner panels are fixed into place, there is no way of poking a pen through the hole to mark it's position. 
So it's back to my trusted templating method using the now empty boxes from GBS. Firstly I cut out a template for the rear wing and then fixed it into position on the car. I used masking tape over the fixing points and drew straight lines at various angles running through the centre of each hole that extended beyond the width of the template. With the template back in place I then re-drew the lines over the template to reveal the fixing points. Moving the template back to the wing I then drilled the fixing holes to 7mm to allow a little play before mounting on the car.
The IVA rules stipulate that the rear lights have to be verticle even though the rear wings aren't. The standard GBS light units have the appropriate rubber mounts that allow this, so mounting them is simply a matter of  finding the point where they are vertical and drilling the fixing holes.



Under the rear wheel arch is probably one of the harshest environments on the vehicle when driving, especially in the wet. I am not happy to let the simple white plastic electrical connector take the brunt of this environment without some form of protection. Looking around my garage I found an old mountain bike inner tube -- perfect!!  A short length with a tie-wrap either end should keep the elements at bay.The final step was a coat of spray underseal to provide some extra protection.
Now onto the front wings. They don't really fit on the cycle wings at all, rather just rest there. So after tacking into position and leaving to set over night I glued into position with plasters beading which seems to be the accepted way of fixing them in place.




Monday, 27 May 2013

Rear Arches

In preparation for fitting the rear arches, tadpole beading is required around their inside edge. Messy job - I have black glue everywhere!!


Saturday, 11 May 2013

Internal tunnel panels and speedo sensor

Time to close up the transmission tunnel. First task today was to offer up the internal panels and drill for the rivets. Then edges of the drivers side panel were given a bead of black glue and the panel riveted into place. I have chosen not to rivet the upper edge as the fixings for the top covers will hold the top in place. Glue should be enough.


With the drivers side in place, the next task is to fit the speedo sensor. The sensor needs to sits 1mm-2mm above the bolt heads of the prop shaft. That's easy with plenty of access, but inside the transmission tunnel its a bit more tricky. I mounted the drivers side bracket, then positioned the sensor before making a template of where the passenger side bracket holes need to be. 


Once I had installed the passenger side panel I then used the template to drive the bracket fixings. The holes needed a little widening but only a mil or so - nothing visible.


Monday, 6 May 2013

IACV

If you have read my blogs from the start you will know that I bought the IACV mounting bracket from RichardL and mounted it on the coil pack bracket.
Thanks to RichardL again, I copied his schematic for the wiring of the IACV.
The default settings in the Emerald software do not use IACV, so you need to select it as an option from the Idle Control screen. I first chose manual control from the menu and used the Page Up key to increase the setting to see if the value was working. As it got to 30% the car started to idle cleanly - wonderful.
Next I switched it into mapped and uploaded the settings again. Idle from start is now smooth, ticking over at about 1000rpm. I let the car warm and adjusted the fan control to force it to turn on. No problem either. 


Lovely day so a great excuse to get a couple of photos of the car so far....
















Another super day, and to finish off I drove the car back into the garage!! First movement under its own power


video

Centre Console

 After the thrill of starting the engine for the first time, it's back to the more mundane jobs.
First the auxiliary switch plate with the start button now installed and working.





Then a tidy up of the spaghetti behind the dash




Then the glueing of the vinyl to the other panels.

Great finish to a milestone day - sitting in the garden on a sunny evening with a glass of Scotch :-)

Saturday, 4 May 2013

Exhaust

Running the engine, even for a short time, without a silencer is a VERY noisy experience in the confirmed space of my garage. So the next job has to be the silencer. So that the mounting bracket doesn't interfere with the rear wheel arch, the manifold needs to be shortened by about 5cm. My dremel made short work of it without needing to remove the manifold. I then pushed the silencer onto the manifold and used its position to guide the position of the bracket. Three 8mm holes later and the bracket was in place.


It looks good and thankfully is nowhere near as load



First Engine Start

There were a number of small jobs that needed doing first. Attaching the fuse box and ECU to the firewall; routing the battery cables through the firewall; and adding a good earthing point.
Once they were complete there was no excuse as to why I couldn't turn the engine over.
I have an old laptop with a serial port so I plugged it in and turned on the ignition. GBS had emailed me the power map so I opened that and set up the Throttle Position Sensor. I decided not to use the IACV just yet to keep things simple.

I turned the key and the engine turned over but didn't fire - bugger. There are only 2 key components that an engine needs: petrol and a spark. Assuming one or both of these were missing I set about trying to analyse what was wrong. I started by disconnecting the HP fuel rail and running the fuel pumps - nothing. I was getting somewhere - no fuel. So I checked back along the fuel route back toward the tank to find the blockage / air lock. I found the problem in the connection between the red nylon pipe and fuel hose. I had missed the brass insert when tightening the jubilee clip and crushed it. Having left some play in the piping I cut the pinched pipe off the end and re-connected. This time fuel spurted from the HP fuel rail when I ran the pumps. So I put it all back together and cross my fingers for a second attempt..............


video

Awesome......
Seems like the Db rating destroyed the mic on my camera. This ones a little better.

video

Clutch & Accelerator Cables

I thought the accelerator cable would go in without much resistance. In fact fitting it to the plenam bracket took less that 10 minutes. But - and there is a but. Once installed there is only about 1cm of travel which hardly opens the throttle. Mmmm. I thought about this for a while and tried repositioning the bracket, but in the end phoned GBS. It turns out that you have to cut 2cm off the plastic bracket and be very careful not to nick the cable itself whilst doing so. As you can see, once this is done you get full travel.
Finally I hadn't completed the lower end of the clutch cable assembly. I have seen various methods of securing the cable to the bell housing, but I haven't any nylocs with the correct thread so it will simply have to remain with the 2 lock nuts for now.
Here is a view of the pedal box with everything now in. I did decide to re-seat the accelerator pedal as I wasn't happy with the fact that it didn't swing freely. The pre-drilled hole in the pedal box needed widening slightly and with a little grease applied it felt a lot better.

Sunday, 28 April 2013

Pedal Box and Accelerator pedal

For the scuttle, pedal box and battery plate, I have used rivnuts and M6 cap heads to hold it all together. I prefer the psychological comfort of being able to easily take it all apart again if needs be, rather than using rivets and "black glue".
By positioning the bolts carefully I have aimed for low visual impact but a strong and robust construction.
Add caption
With the peddle box now in place, I could think about the pedals again. I connected the clutch cable - straightforward. (I still need to adjust the cable from the lower clutch arm connectors). Then the accelerator. After talking to Richard@GBS the last time I was at the factory, he recommended grinding down on side of the pivot tube almost down to the weld. This will bring the pedal across slightly and make it easier to drive. You don't need to use the pre-drilled hole in the pedal box, but I have chosen to as it would need filling if I didn't. I is not quite lined up which means the pedal is not swinging absolutely freely. Once I have connected the accelerator cable I will check if this is a problem and adjust if I must.